Authentication disruptions

Incident Report for NordPass

Resolved

All services are operating as usual.
Posted Feb 23, 2026 - 18:00 EET

Update

We are continuing to work on a fix for this issue.
Posted Feb 23, 2026 - 17:59 EET

Identified

Applications and services may take longer to respond due to increased load.
Posted Feb 23, 2026 - 16:30 EET

Update

We are continuing to investigate this issue.
Posted Feb 23, 2026 - 16:29 EET

Investigating

Investigating authentication login issues affecting NordPass access.
Posted Feb 23, 2026 - 15:46 EET
This incident affected: Login/SSO (Login/SSO (US), Login/SSO (EU)) and NordPass Vault Services (NordPass Vault Services (US), NordPass Vault Services (EU)).